Recently Updated

My Services

Blog: Upgrading Your Zen Cart

Feb282015

Now that Zen Cart v1.5.4 has been out for a couple of months, more shop-owners are looking to upgrade their Zen Cart software to that version.  As such, I thought that I’d provide a couple of suggestions and hints to help in that transition.

  1. If your current store’s Zen Cart version is pre-v1.5.0, I suggest that you re-build your site rather than upgrade.
    • The admin-level interface changed significantly in the Zen Cart v1.3.9-to-v1.5.0 transition, so most of your admin-level plugins will require update to properly run under Zen Cart v1.5.4.
    • The admin-level configure.php file’s contents were updated for v1.5.0, making it “adapt” to your changing of your admin folder’s name.
  2. You’ll need to review each of the plugins you’ve included in your store, since the PHP language has evolved over the past  years.  Many of the older plugins have been updated to remove the use of deprecated PHP features and functions (like short-codes and the ereg_* functions) and some use direct mysql_* PHP calls instead of using the Zen Cart $db object.
  3. The longer you wait, the more changes (both improvements and bugfixes) are introduced into the core code — increasing the number of files to be compared during your upgrade.
  4. Make sure that you have subscribed to the Known Bugs (and fixes) with v1.5.4 thread on the Zen Cart forums.
  5. Watch out for the template-file changes introduced (especially in Zen Cart v1.5.3 and v1.5.4).  If your store uses the Product URL feature, you’ll need to update your product-details’ pages since the Zen Cart interface to display that URL was changed in v1.5.3.

May your upgrade be successful!

Copyright © 2012-2021 Vinos de Frutas Tropicales. Powered by Zen Cart