Nov 162012
 

Your store is based on Zen Cart v1.5.0 or later and you’ve used your admin’s Admin Access Management -> Admin Profiles to create a profile for some admin users that will have less than “Superuser” authority … let’s call that profile Manager.  Within the Manager profile, you give those users permission to access the admin_sample plugin.

The first time an admin user with the Manager profile tries to use the admin_sample plugin, they’re presented with the message:

Sorry, your security clearance does not allow you to access this resource.

When this happens, the first thing to check is the file that’s included with the plugin that defines the plugin’s filename, usually named something like /YOUR_ADMIN/includes/extra_datafiles/admin_sample_filenames.php.  You’re looking for a define that’s similar to:

  define(‘FILENAME_ADMIN_SAMPLE’, ‘admin_sample.php”);

The problem is the part highlighted in red; you’ll need to change that line to remove the .php portion:

  define(‘FILENAME_ADMIN_SAMPLE’, ‘admin_sample”);

Once that change is made, all your non-Superuser admin’s that should have access to the admin_sample tool will be able to use it.

P.S.  It would be a good thing to make a posting in the support thread of the plugin that you had to change to let the author and other users know of the situation!

  One Response to ““Sorry, your security clearance does not allow you to access..””

  1. Thank you so very much for this information. Worked like a charm.

Sorry, the comment form is closed at this time.